Transitmania 10 @Santa Pod 18th to 20th May 2018


MK6 Not charging but no battery / alternator light

Use this forum to post technical questions & problems about any Transit

Moderator: Luke

MK6 Not charging but no battery / alternator light

Postby mbuk » Tue Aug 08, 2017 8:15 am

Currently in France with our MK6 2004 LWB RWD camper van. Was serviced in July and has been faultless for last 5 years.

Last night while driving on motorway First sign of issues was ABS light flashing on.

We stopped at an service station and once engine stopped wouldn't start (flat battery) Jumped started it with a leisure battery no problem. But was clearly not charging (no increased voltage at battery when engine running)
Now recovered to garage and obviously suspect Alternator. But wondered why no warning light? It does come on with ignition but goes off once jump started.

Have checked fuses in engine bay.

Any ideas?

Mike
mbuk
Transit Fan
Transit Fan
 
Posts: 10
Joined: Sat Aug 07, 2010 8:24 pm

Re: MK6 Not charging but no battery / alternator light

Postby the dutch guy » Tue Aug 08, 2017 8:53 pm

alternator light comes from the alternator. if it really gave up then the warning will not work also as the light is a integral part of the alternator, at least it was with older "dumb" alternators.

with older alternators the light does work by a balance. When you turn on the key, 12 volts is supplied to the alternator's field windings through the idiot light. This gives an indication that the alternator's field circuit is intact, and it also provides the current to start the alternator charging. In fact, the alternator may fail to charge if that light bulb is burned out. When the engine starts and gets up to a high enough rpm for the alternator to start putting out voltage, there is a diode inside that takes some of the output voltage and featured back to the terminal that goes to the idiot light. The net result of this is that when the engine is running and up to proper rpm, the idiot light is receiving 12 volts at both ends, which means that the total voltage drop across the light is the zero volts and the light doesn't light.

i do believe the mk6 has one of those new fangled smarty pants alternators that work differently and regulate the voltage down when the battery is charged.

in any case: alternator needs a rebuild/replacement.

might also want to checkt the battery, if that thing gave up completly it will hold no charge and the alternator will have to do all the work. but considering the abs indicated a low voltage during driving i put my money on the alternator. but let the garage do a load test to see if the battery is still up to par. if its bad it can kill alternators real fast.
Mk6 SWB TDCI 125
the dutch guy
Transit Aficionado
Transit Aficionado
 
Posts: 188
Joined: Sun Jul 09, 2017 12:22 am

Re: MK6 Not charging but no battery / alternator light

Postby mbuk » Sun Aug 13, 2017 9:03 am

Thanks for the info that could explain the charging fail light not coming on.

The garage were great and load tested the battery and check the alternator and the alternator had totally failed. There was also a big crack in the casing when they took it off.

For speeds sake had to stump up for a new FoMoCo alternator rather than finding a recon so not cheap but all sorted and had pulleys / belts changed at same time.

We were back on the road 18 hours after recovery so holiday continues
mbuk
Transit Fan
Transit Fan
 
Posts: 10
Joined: Sat Aug 07, 2010 8:24 pm


Return to Technical Problems & Questions



Who is online

Users browsing this forum: No registered users