Ford Fair 2014 - click here for details of the forum's stand!


Problems with LDV convoy (Duratorque Transit Engine)

Use this forum to post technical questions & problems about any Transit

Moderator: Luke

Problems with LDV convoy (Duratorque Transit Engine)

Postby olstonsurf » Fri Jan 20, 2012 10:53 am

Hi i hope someone can help me with my 2.5 ldv convoy.

I had it idleing for about 3 minutes and when i went to set off there was nothing coming from the accelerator , first i thought it was a cable but it didnt fel like it , so i managed to park it up, turned it off and back on and it worked again, so turned if off and on again but had trouble starting it till it finally fired up!!
This is one of many problems im having with this van , the full beam is constantly on when lights are on and when i try turning down theres a relay ticking by ECU (Which has just been replaced with the key reader after another problem )

One problem after another ! :x :x :x :x
olstonsurf
Newbie
 
Posts: 4
Joined: Fri Jan 20, 2012 10:44 am

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby hortons » Fri Jan 20, 2012 12:16 pm

olstonsurf wrote:Hi i hope someone can help me with my 2.5 ldv convoy.

I had it idleing for about 3 minutes and when i went to set off there was nothing coming from the accelerator , first i thought it was a cable but it didnt fel like it , so i managed to park it up, turned it off and back on and it worked again, so turned if off and on again but had trouble starting it till it finally fired up!!
This is one of many problems im having with this van , the full beam is constantly on when lights are on and when i try turning down theres a relay ticking by ECU (Which has just been replaced with the key reader after another problem )

One problem after another ! :x :x :x :x

hi
your headlight problem is caused by a dirty connection on one of your headlight bulbs pull then off one at a time till the noise stops,you will find one of the connections is burnt,you may need to get a new plug [only a couple of quid]
regards Barry
hortons
Transit Addict
Transit Addict
 
Posts: 40
Joined: Sun May 02, 2010 7:52 pm

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby arrow » Fri Jan 20, 2012 2:44 pm

2.5 duratorq?
I don't think so !
arrow
Transit Addict
Transit Addict
 
Posts: 32
Joined: Sun Jan 23, 2011 11:43 am

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby olstonsurf » Fri Jan 20, 2012 7:43 pm

hortons wrote:your headlight problem is caused by a dirty connection on one of your headlight bulbs pull then off one at a time till the noise stops,you will find one of the connections is burnt,you may need to get a new plug [only a couple of quid]
regards Barry


Cheers Ill have a go tomorow :D
olstonsurf
Newbie
 
Posts: 4
Joined: Fri Jan 20, 2012 10:44 am

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby Altransit » Fri Jan 20, 2012 8:07 pm

olstonsurf wrote:Cheers Ill have a go tomorow :D

Have a look to see which engine you have, pre 2002 build, it will be a 2.5TDi, after that it will be a 2.4 TDDi Duratorq :wink:
1997 Mk5 SWB 115 Minibus 70ps Di
2004 Mk6 SWB T280 Medium Roof 85PS TDDi - Vantunered
User avatar
Altransit
Site Moderator
 
Posts: 20691
Joined: Tue Oct 17, 2006 12:23 am
Location: Bicester, Oxfordshire

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby Frag » Fri Jan 20, 2012 8:19 pm

In my very limited experience,Convoys seem to suffer from water ingress thru screen seal which causes electrical 'issues' to modules under dash etc.

Lack of accelerator response could be pedal itself,fairly common on the transit if same pedal assy.
User avatar
Frag
Ford Technician
 
Posts: 2949
Joined: Sat Jul 05, 2008 3:05 pm

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby olstonsurf » Sat Jan 21, 2012 11:06 am

Altransit wrote:Have a look to see which engine you have, pre 2002 build, it will be a 2.5TDi, after that it will be a 2.4 TDDi Duratorq



its a 2002 convoy so itll be the 2.4 tddi, ive had loads of bother with it to be honest.
Thanks
olstonsurf
Newbie
 
Posts: 4
Joined: Fri Jan 20, 2012 10:44 am

Re: Problems with LDV convoy (Duratorque Transit Engine)

Postby olstonsurf » Sat Jan 21, 2012 11:08 am

Frag wrote:In my very limited experience,Convoys seem to suffer from water ingress thru screen seal which causes electrical 'issues' to modules under dash etc.

Lack of accelerator response could be pedal itself,fairly common on the transit if same pedal assy.



Ye i had to buy a new ECU due to the water corrosion on it
THanks
olstonsurf
Newbie
 
Posts: 4
Joined: Fri Jan 20, 2012 10:44 am


Return to Technical Problems & Questions



Who is online

Users browsing this forum: No registered users