Transitmania 9 @Santa Pod 23rd - 24th September 2017 Click here for details!


Ex bt transit weird indicator problem...

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Ex bt transit weird indicator problem...

Postby rockymtnslayer » Fri Apr 21, 2017 12:32 pm

Hi lads i have had the transit a day now and its started doing a weird thing when indicating right and driving along it ticks normally, as soon as i put my foot on the brake the indicator speeds up like theres a blown bulb, foot off the brake and its back to normal.

I had a mate follow the van and he said the osr tailight is very very weak in terms of out put compared to the other side.

This a common fault/ any ideas?? Bulbs are the same both sides.
rockymtnslayer
Transit Addict
Transit Addict
 
Posts: 21
Joined: Tue Jun 30, 2015 4:13 pm

Re: Ex bt transit weird indicator problem...

Postby blue estate » Fri Apr 21, 2017 12:59 pm

Take back light unit out and clean the writing connections as they're prone to corrosion


Sent from my iPad using Tapatalk
mk2.5 Focus zetec 1.8tdci 09 hatch
mk4 Escort estate 1.3 yellow
My other car is a 26t Mercedes Actros 360 6x2 rigid curtain sider with tuck under tail lift and tag axle and Fridge :D
I may drive a Mercedes truck but I will only drive a Ford Transit van
User avatar
blue estate
Remapped by Vantuner
 
Posts: 14823
Joined: Sat Dec 18, 2010 9:14 pm
Location: week days a lay by some where

Re: Ex bt transit weird indicator problem...

Postby rockymtnslayer » Fri Apr 21, 2017 4:08 pm

Cheers mate ill give it a clean tonight, ta
rockymtnslayer
Transit Addict
Transit Addict
 
Posts: 21
Joined: Tue Jun 30, 2015 4:13 pm

Re: Ex bt transit weird indicator problem...

Postby MrFlibble » Fri Apr 21, 2017 4:27 pm

Sounds like a bad earth connection on the rear light cluster.
2003(52) Mk6 90 T350 2.4TDDi LWB RWD medium roof
MrFlibble
Transit Aficionado
Transit Aficionado
 
Posts: 337
Joined: Mon Jun 18, 2012 6:31 am

Re: Ex bt transit weird indicator problem...

Postby rockymtnslayer » Mon Apr 24, 2017 10:25 pm

Hi lads.

I have checked the connections couldnt source an earth wire so that may be the issue but a weirder thing happened i went out to drive it tonight got in turned the key and put my foor on the brake once the hand brake was on and noticed in the reflection of a car in front that the front right indicator bulb lit up on a constant glow when ever i had my foot on the brake. So im guessing dodgy wiring going on here?

Should i just take it to an auto electrician if there is such a thing? Cheers in advance.
rockymtnslayer
Transit Addict
Transit Addict
 
Posts: 21
Joined: Tue Jun 30, 2015 4:13 pm

Re: Ex bt transit weird indicator problem...

Postby rockymtnslayer » Sun Apr 30, 2017 10:32 pm

Turned out to be inside the bulb holders loads of corrosion causing electrical issues. 2 new bulb holders and new bulbs and the indicators work properly again wahoo. Nows time for a bloody good clean.
rockymtnslayer
Transit Addict
Transit Addict
 
Posts: 21
Joined: Tue Jun 30, 2015 4:13 pm


Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Bing [Bot]