Transitmania 10 @Santa Pod 18th to 20th May 2018


Dreaded mk6 speedo fault

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Re: Dreaded mk6 speedo fault

Postby daz1412 » Mon Sep 18, 2017 9:59 pm

Sadly I can't rework it. the ones I need have no cables in them I'll try strip the old cables out and re do it, failing that could i just loop the cables at the loom end where needed?

Again, cheers for the help everyone. really appreciate it. One of the best forums i've used.
daz1412
Transit Addict
Transit Addict
 
Posts: 51
Joined: Wed May 03, 2017 10:35 pm

Re: Dreaded mk6 speedo fault

Postby daz1412 » Mon Sep 18, 2017 10:30 pm

I've already cut two of the wires to attempt a rearrange but it never worked. Mine was wired as is seen below.
You do not have the required permissions to view the files attached to this post.
daz1412
Transit Addict
Transit Addict
 
Posts: 51
Joined: Wed May 03, 2017 10:35 pm

Re: Dreaded mk6 speedo fault

Postby APH » Mon Sep 18, 2017 10:42 pm

you can re use that, if you release the locking tabs the terminals will slide out and you can put them back where they should be, solder wires together, or crimp them and it should work, however, you can easily work out the wires on the other side of the loom to join together too if you don't want to use he plug, as you can see the positions of the two link wires in that other picture you posted. so can look at what colours they correspond too on the main van wiring harness.

Andy :D
Image
03 2.4 TDDI 90 t350 LWB HR white panel van
X reg 2.4 TDDI 90 t350 MWB MR Yellow Panel van
56 reg lwb high roof connect, 1.8 tdci 90 t 220


(\__/)
(='.'=)
(")_(")

this is bunny

copy and paste to help bunny gain world domination
User avatar
APH
Transit Fanatic
Transit Fanatic
 
Posts: 2332
Joined: Thu Apr 12, 2007 7:29 pm
Location: Gravesend, Kent

Re: Dreaded mk6 speedo fault

Postby APH » Mon Sep 18, 2017 11:21 pm

On the van loom, join white/green to white/violet, and join yellow to blue

Andy :D
Image
03 2.4 TDDI 90 t350 LWB HR white panel van
X reg 2.4 TDDI 90 t350 MWB MR Yellow Panel van
56 reg lwb high roof connect, 1.8 tdci 90 t 220


(\__/)
(='.'=)
(")_(")

this is bunny

copy and paste to help bunny gain world domination
User avatar
APH
Transit Fanatic
Transit Fanatic
 
Posts: 2332
Joined: Thu Apr 12, 2007 7:29 pm
Location: Gravesend, Kent

Re: Dreaded mk6 speedo fault

Postby daz1412 » Tue Sep 19, 2017 3:46 pm

Scrap that. It's working, realised I had removed the fuse the other day. I have a speedo! Reverse switch - check. Speedo - check. Now to get the welding done. Thank you very much for the help chaps.
daz1412
Transit Addict
Transit Addict
 
Posts: 51
Joined: Wed May 03, 2017 10:35 pm

Re: Dreaded mk6 speedo fault

Postby andz327 » Tue Sep 19, 2017 8:44 pm

daz1412 wrote:Is this the reverse switch? Seems to be one bolt but still isn't loose after removing said bolt.
That picture looks like a crankshaft sensor mate
User avatar
andz327
Transit Fanatic
Transit Fanatic
 
Posts: 2005
Joined: Thu Jan 14, 2016 3:44 am

Re: Dreaded mk6 speedo fault

Postby nedforceone » Tue Sep 19, 2017 9:01 pm

daz1412 wrote:Scrap that. It's working, realised I had removed the fuse the other day. I have a speedo! Reverse switch - check. Speedo - check. Now to get the welding done. Thank you very much for the help chaps.


Was it the bridge on the tacho wiring that got it working again (and the fuse)?. N
03 transit 125t280 2.0 tdci swb executive collage blue 92 crewcab. Built in Belgium so deserves lots of love. 206,000 miles on the clock.

Instructions for use. fill with fuel. start engine. drive like a t#@t.
User avatar
nedforceone
Transit Extremist
Transit Extremist
 
Posts: 7769
Joined: Sat Jan 16, 2016 9:01 am
Location: winsford, cheshire

Re: Dreaded mk6 speedo fault

Postby daz1412 » Thu Sep 21, 2017 3:22 pm

Yep, the bridge sorted it. feel like a bit of a tit having traced wires here there and everywhere. the main thing is it's sorted. Will make it a lot easier to sell when the time comes.

Thanks chaps!
daz1412
Transit Addict
Transit Addict
 
Posts: 51
Joined: Wed May 03, 2017 10:35 pm

Re: Dreaded mk6 speedo fault

Postby Really Good Idea » Tue Sep 26, 2017 9:54 pm

daz1412 wrote:Yep, the bridge sorted it. feel like a bit of a tit having traced wires here there and everywhere. the main thing is it's sorted. Will make it a lot easier to sell when the time comes.

Thanks chaps!


So how did you fix this?
I've still got the same problem after soldering and not sure what I should be checking next :/

Here is a picture of some loose connectors behind the instrument panel

Image

Here are FOUR different loose connectors by the passenger side fuse box
Image

Any hints as to where any of these should go?
Please help me fix up my van into a camper!
Transit 06 90 T350 TDDi - LWB High Top, one green door
Really Good Idea
Transit Fan
Transit Fan
 
Posts: 12
Joined: Sun Sep 17, 2017 8:37 pm

Re: Dreaded mk6 speedo fault

Postby Really Good Idea » Wed Oct 04, 2017 11:20 am

Any help?
Please help me fix up my van into a camper!
Transit 06 90 T350 TDDi - LWB High Top, one green door
Really Good Idea
Transit Fan
Transit Fan
 
Posts: 12
Joined: Sun Sep 17, 2017 8:37 pm

Previous

Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Baidu [Spider]