Transitmania 10 @Santa Pod 18th to 20th May 2018


Mk7 transit ecu pin layout

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Mk7 transit ecu pin layout

Postby thanuttiscotsman » Tue Sep 19, 2017 6:09 pm

Hi folks, as it says above I'm looking for the ecu pin layout for mk7 2007 2.2 diesel fwd 85ps. I have an issue with abs and tc lights being on and fault code u1a04 (invalid speed signal from abs module to ecu) so I'm trying to locate the specific wire to check it end to end.

Also has anyone else ever come across the code?, if so what was the issue in your case?

Many thanks in advance for any info as I've googled my ars* off today and got nowhere with that or the Haynes.

Rossco
1996 transit swb 80 2.5di
1989 bx 16 valve gti nos and all the rest!
thanuttiscotsman
Transit Aficionado
Transit Aficionado
 
Posts: 141
Joined: Mon Nov 10, 2008 1:12 am
Location: edinburgh

Re: Mk7 transit ecu pin layout

Postby knobby1 » Tue Sep 19, 2017 8:18 pm

I'd be checking the ABS sensors on each wheel...could possibly have a duff sensor or loom...

Sometimes the reluctor rings themselves can break in half and even fall off...!

Lord Knobrot
2008 2.4L RWD 170+PS 6-speed 350 LWB High Roof.

When I die, I want to go peacefully in my sleep like my Grandfather, not screaming like the passengers in his car..!
User avatar
knobby1
Transit Fanatic
Transit Fanatic
 
Posts: 4670
Joined: Tue Oct 21, 2014 1:36 am
Location: Sydney, Australia

Re: Mk7 transit ecu pin layout

Postby v8dave » Tue Sep 19, 2017 8:38 pm

The signal is done by canbus not an individual wire.

Check the abs wiring and sensors as Knobby1 suggests.

You could also make sure the three connectors onto the ecu are clean, dry and secure.
Plus make sure your earth connections are good, these can get corroded after 10 years.
mk7 08reg 2.4 T350 LWB MHR RWD
mk6 X reg 2.4 T350 LWB MHR RWD - scrapped
mk4 J reg 2.5 L300 LWB MHR RWD - sold on

Notice a trend there ? not too big and not too small
User avatar
v8dave
Transit Fanatic
Transit Fanatic
 
Posts: 2365
Joined: Sun Jan 24, 2010 10:23 pm
Location: Home counties

Re: Mk7 transit ecu pin layout

Postby thanuttiscotsman » Wed Sep 20, 2017 8:35 am

Hi guys, thanks for the response. I should have also said that I have already tested the sensors and replaced osr as it was open circuit. All the rings are complete and in general good condition so I'm happy with the sensors and rings.
I'll go check the earthing now as I've not done that.
I have also checked that pin 3 on the abs loom plug is live and it's good.
Any other ideas other than the earth?

Many thanks, rossco
1996 transit swb 80 2.5di
1989 bx 16 valve gti nos and all the rest!
thanuttiscotsman
Transit Aficionado
Transit Aficionado
 
Posts: 141
Joined: Mon Nov 10, 2008 1:12 am
Location: edinburgh

Re: Mk7 transit ecu pin layout

Postby thanuttiscotsman » Wed Sep 20, 2017 10:58 am

Hello again, I have found two rotten earths on the top of the left wheeel arch under the bonnet, repaired both of them checked earth but still no joy. Also all fuses are ok.

I'm out of ideas yet again ad can only go on the fault code U1A04 invalid signal from ecu to abs module.

Again does anyone have the ecu pin layout?, the signal must be carried along one of the wires which I should at least check for continuity.

Cheers, rossco
1996 transit swb 80 2.5di
1989 bx 16 valve gti nos and all the rest!
thanuttiscotsman
Transit Aficionado
Transit Aficionado
 
Posts: 141
Joined: Mon Nov 10, 2008 1:12 am
Location: edinburgh

Re: Mk7 transit ecu pin layout abs + tc lights SOLVED

Postby thanuttiscotsman » Wed Sep 20, 2017 12:28 pm

Hello folks, this issue has now been resolved so I shall share my experience in the hope it will assist someone one day.

I had abs and tc lights on the dash. After changing an abs sensor that had no continuity lights were still on. I noticed the hook on top of engine was rather bent which indicated to me that possibly the engine had been changed at some point and been swinging around on a crane. Upon inspecting the full length of all the abs wiring I found that the wiring loom that runs from the abs module/fuse box to the rear chassis was damaged on the front left chassis inner leg, it appeared like it had been lumped with a hammer (or likely the gearbox when the potential engine swap was being done). Anyway one of the bashed wires was burst open and had rotted out fully, split in two in my hand. Repaired two of the wires and upon driving the vehicle at 5/10 mph the lights have all gone out and all is working.

The only info the transit offered up to identify this fault was the fault code U1A04.

Hope this is of use to someone.

Cheers
1996 transit swb 80 2.5di
1989 bx 16 valve gti nos and all the rest!
thanuttiscotsman
Transit Aficionado
Transit Aficionado
 
Posts: 141
Joined: Mon Nov 10, 2008 1:12 am
Location: edinburgh

Re: Mk7 transit ecu pin layout abs + tc lights SOLVED

Postby MK7 user » Wed Sep 20, 2017 8:31 pm

thanuttiscotsman wrote:Hello folks, this issue has now been resolved so I shall share my experience in the hope it will assist someone one day.

Cheers


Good info buddy....glad you've got sorted. 8)
The Eleventh Commandment:
Thou Shalt Not Beat Thy Hood....Like a "Toss Jockey Sprinter Driver" :!:
V184 wrote:That prat calls me a "tosser" because I own a Sprinter & chime into a Transit forum :shock:
User avatar
MK7 user
Transit Devotee
Transit Devotee
 
Posts: 1445
Joined: Fri Nov 30, 2012 1:43 am
Location: Grim HQ in the parish of Aston Nr the Great Hall


Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot]