Transitmania 10 @Santa Pod 18th to 20th May 2018

Brakes Issue

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Brakes Issue

Postby DustyPete » Sun Feb 18, 2018 7:25 pm

Hi guys hoping you can shed some light on a brake problem im having

55 plate 260 85ps swb fwd transit on approx 125k

Bought van recently and the brakes were terrible so had new front discs, pads and wheel bearings done and had the brakes bled. It's basically made no difference at all (appart from to my wallet)

Recently when ive been braking you can feel (but not hear) a grinding sensation through the pedal. Not always, but sometimes.

Sometimes when i brake it is using the top inch of travel and sometimes i have to depress the pedal all the way to the floor to get any result.

I beleive it had abs when new. It does not appear to have now! I braked very hard the other night to avoid remodeling the rear end of a focus and nothing happened abs wise

If anyone can point me in the right direction(s) i would be very grateful indeed
Posts: 1
Joined: Sun Feb 18, 2018 7:11 pm

Re: Brakes Issue

Postby knobby1 » Wed Feb 21, 2018 10:00 pm

Did you use IDS or Forscan to bleed the brakes..?? The ABS module possibly still has air in it, to bleed it properly you need to activate the ABS module via IDS or Forscan.

With the grinding noise, did you do the rear brakes as well..??

Lord Knobrot
2008 2.4L RWD 170+PS 6-speed 350 LWB High Roof.

When I die, I want to go peacefully in my sleep like my Grandfather, not screaming like the passengers in his car..!
User avatar
Transit Extremist
Transit Extremist
Posts: 5835
Joined: Tue Oct 21, 2014 1:36 am
Location: Sydney, Australia

Return to Mk6 & Mk7 - Third Generation Transits

Who is online

Users browsing this forum: FordDriver, Google [Bot]