Transitmania 6 @ Billing Aquadrome Aug 22nd to 24th 2014


Mk7 EGR valve - Disconnect?

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Re: Mk7 EGR valve - Disconnect?

Postby gpz900r » Tue Jan 06, 2009 9:01 pm

coconut wrote:
gpz900r wrote:hi my mechanic who works at ford blanked it off with some sort of washer no probs whats so ever done at lest 8000 miles so far since its been done i beleive it just recycles unburnt gases someone will put me right if this isnt the case.


Is yours a mk7 :?:

If so, any chance of speaking to him and finding out how he done it :D
wont see him till next week will ask him what he done and with what he blank it off with mines a 55 350t 137ps jumbo dont no if you class as a mk7 or mk6
gpz900r
Transit Addict
Transit Addict
 
Posts: 48
Joined: Mon Jan 05, 2009 4:30 pm

Re: Mk7 EGR valve - Disconnect?

Postby tanvics » Tue Jan 06, 2009 9:27 pm

mines off into lincoln ford on thursday engine managment light on its been on for 2 weeks code read says egr mixture fault or something like that see if they sort it this time this is the 3rd egr valve in 34000 miles
i was suprised that it didnt put the van in limp mode though
tanvics
Transit Addict
Transit Addict
 
Posts: 42
Joined: Fri May 25, 2007 9:24 pm

Re: Mk7 EGR valve - Disconnect?

Postby pikeybob » Thu Jan 08, 2009 9:20 pm

mk7 is the latest shape stacked headlights & really small Ford badge on the grill :lol: :lol:
The only mk7 still with ORIGINAL egr valve!!!!!!
User avatar
pikeybob
Transit Devotee
Transit Devotee
 
Posts: 690
Joined: Mon Oct 13, 2008 6:01 pm
Location: notts

Re: Mk7 EGR valve - Disconnect?

Postby martynx » Fri Jan 09, 2009 1:43 am

I blanked 2 mk7's & neither ran right, typically they stalled when reversing on slight incline with no throttle or it messed up the low rpm ( up to 2000rpm) throttle response..

On my own van , eventually the blank plate ( actaully a carlsberg can ) burnt through & it coughed a bit & then ran good again & ever since :lol:
Last edited by martynx on Fri Jan 09, 2009 9:16 pm, edited 1 time in total.
Vantuner is away till
4th September





Mk7 Ex Rac 3.2 200T260

Mk2 V8 getting dusty

Mk6 College Blue 100ps Executive - Still in the family

Cruise Control activations, Egr off & more at vantuner.com :)
User avatar
martynx
Transit Fanatic
Transit Fanatic
 
Posts: 2499
Joined: Sat Feb 03, 2007 1:50 pm
Location: Nr. Uxbridge Middlesex

Re: Mk7 EGR valve - Disconnect?

Postby Playminiii » Fri Jan 09, 2009 5:38 pm

Mines a 08 plate 140ps Tourneo :-( not a proper Transit but nearly there its done 68k on its third EGR an which was fitted on Monday 5 jan and guess what its still the same i'm debating whether it is the egd sometimes when you give it a good boot it feels like it lags to hell if u come off the power and back on quick it sounds like the boost dump and it does it again then the EML comes on and it goes in Limp home np happy days when your doing 70 in the outside lane. when plugged in there is 1 fault "overboost" but also cold morings and when ticking over for a while it is lumpy as hell. its constantly services oil evry 10 k and everything else every 20k which is far more that what ford reccomend. and always use the same fuel which is the same fuel in the other 8 140 ps vans i use which never had this problem!!!!!! anyone any ideas its going back for 2 days next week be nice to be able to tell them whats up fed up of it been in it lives there!!!
TRansit Tourneo 140ps Goes like the Wind and still returns 34.2mpg pure magic!!!! But at 450k its starting get Tired!!!!
Playminiii
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Aug 15, 2008 12:24 pm

Re: Mk7 EGR valve - Disconnect?

Postby glenandemm » Fri Jan 09, 2009 7:21 pm

hi i just saw your message abou the overboost and had a citroen hdi a while ago that came up with the same fault and turned out the wastegate rod was sticking causing it to overboost,now im not sure what the transits wastegate are like but maybe something to consider,sticking wastegate rod?
glenandemm
Transit Devotee
Transit Devotee
 
Posts: 1165
Joined: Tue Feb 28, 2006 7:10 pm
Location: stockport

Re: Mk7 EGR valve - Disconnect?

Postby Playminiii » Fri Jan 09, 2009 8:51 pm

well i think from what i've seen and been told its got electronic wastegate i suppose the ecu might not be sending the right signals or thats gone up the pan it does it quite warm and to be fair i'm sure the 2.2 is based on a psa 2.2hdi engine so you may be somewhere along the right track i have got to say when its not playing up it flys but when it is its slow and thirsty
TRansit Tourneo 140ps Goes like the Wind and still returns 34.2mpg pure magic!!!! But at 450k its starting get Tired!!!!
Playminiii
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Aug 15, 2008 12:24 pm

Re: Mk7 EGR valve - Disconnect?

Postby atlantic909 » Tue Jan 20, 2009 9:09 am

I have a 57 plate 130 GLX 2.2 Tourneo minibus. My bus has exactly the same symptons described here. When warm I loose power when starting off from lights etc , changing gear , when I accelerate and when going fast on the Motorway. Its back into Ford (again!!!) next week.

I bought the bus 15th December 2007 for use as a taxi. First new vehicle I ever bought! When it runs right its fantastic

As well as the problem in this thread Ive had

* Bad hunting and cutting out since 7,000 miles - still not sorted
* Dosent start after re-fuelling , stalling or general starting when its been running a while - still not sorted
* EGR - Ford replaced this
* Clutch failure at 47,000 on Christmas day - They blamed driver abuse (£946 bill and ongoing dispute, I took a mechanic out on a road test 8 days before the failure to show the cutting out problem and to show him the clutch was riding, they said it would be ok and was booked in 7th Jan 09)
* £240 45,000 Service then 1 week later failed its Taxi test due to split CV boot on main driveshaft (it was totally dry) and back number plate light holder broken (problem they was told about). They charged but didnt put screenwash in. Got a big apology and my Taxi test fee re-funded
* Split Power steering pipe - sorted

Various other problems and Im at my wits end. I find it next to impossible to source information on the net about Tourneos apart from ones that are for sale.

I really like the bus it but am I just unlucky ?
atlantic909
Newbie
 
Posts: 3
Joined: Sun Jan 11, 2009 12:24 pm

Re: Mk7 EGR valve - Disconnect?

Postby Hilborns Motorsport » Wed Jan 28, 2009 12:08 am

We May Have the answer to the EGR Problem i Will Keep You Up Dated
we are Developing the EGR Vale to stay closed loop cycle with in the map in the ECU and ajust fueling Ect to suit and reconise it dont need data from EGRValve with out making poor idle and light coming on should be able to as we do this with some other diesels we map and it dont cause any problems.

this will be for the 2.2 and 2.4 Tdci
Hilborns Motorsport
Sportvan Owner!
Sportvan Owner!
 
Posts: 26
Joined: Tue Jan 13, 2009 7:33 pm

Re: Mk7 EGR valve - Disconnect?

Postby Victer van man » Wed Jan 28, 2009 10:30 pm

Sounds good to me :) :) fed up with buying new ones
Just one question..... my van's been remapped will it affect it?
[b]Jumbo driver's go the distance[/b
User avatar
Victer van man
Transit Aficionado
Transit Aficionado
 
Posts: 285
Joined: Wed Mar 28, 2007 9:07 pm
Location: Exeter Devon

Re: Mk7 EGR valve - Disconnect?

Postby Hilborns Motorsport » Wed Jan 28, 2009 10:35 pm

Victer van man wrote:Sounds good to me :) :) fed up with buying new ones
Just one question..... my van's been remapped will it affect it?

this is what we are checkinh and developing as we MAP other cars and can take it out we seeing if we can take it out and also take it out when Maping Ecu. will update when we developed more
Hilborns Motorsport
Sportvan Owner!
Sportvan Owner!
 
Posts: 26
Joined: Tue Jan 13, 2009 7:33 pm

Re: Mk7 EGR valve - Disconnect?

Postby Victer van man » Wed Jan 28, 2009 11:15 pm

Thank's keep us posted
[b]Jumbo driver's go the distance[/b
User avatar
Victer van man
Transit Aficionado
Transit Aficionado
 
Posts: 285
Joined: Wed Mar 28, 2007 9:07 pm
Location: Exeter Devon

Re: Mk7 EGR valve - Disconnect?

Postby pikeybob » Thu Jan 29, 2009 6:14 pm

Hilborns Motorsport wrote:We May Have the answer to the EGR Problem i Will Keep You Up Dated
we are Developing the EGR Vale to stay closed loop cycle with in the map in the ECU and ajust fueling Ect to suit and reconise it dont need data from EGRValve with out making poor idle and light coming on should be able to as we do this with some other diesels we map and it dont cause any problems.

this will be for the 2.2 and 2.4 Tdci


Perhaps u could advise Ford how to fix it :lol: :lol:
The only mk7 still with ORIGINAL egr valve!!!!!!
User avatar
pikeybob
Transit Devotee
Transit Devotee
 
Posts: 690
Joined: Mon Oct 13, 2008 6:01 pm
Location: notts

Re: Mk7 EGR valve - Disconnect?

Postby mrg » Thu Jan 29, 2009 6:53 pm

Hi, pusd, i have a mk6 tourneo and after changing my 2lt for a 2.2lt found i was losing boost through the egr, so just cut ally gasket and fitted it to block the flow of gasses into the intake, valve thinks its working fine and no lights. ps, who wants all that s*** being sucked back into the engine anyway. it might not work on the mk7 but cant see why, it would take some fancy sensors to tell if its running on soot. typing is not up to mutch at moment, broke wrist up ice skating.
mrg
Transit Addict
Transit Addict
 
Posts: 20
Joined: Mon Aug 25, 2008 7:53 pm

Re: Mk7 EGR valve - Disconnect?

Postby madmark » Thu Jan 29, 2009 8:28 pm

is there no way that some clever person could get the wires in the plug to the egr and somehow make a conection so that it thinks its conected if you get what i meen! :idea: :idea:
my mk6 is a nightmere with the egr conected but i am lucky i run with it disconected as its vacum fed rather than eletric!
these egr ishues are big problems! :( :( and will put me off owning a mk7! :(
madmark
Transit Extremist
Transit Extremist
 
Posts: 15499
Joined: Thu Mar 03, 2005 4:29 am

PreviousNext

Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Loui9258