Transitmania 6 @ Billing Aquadrome Aug 22nd to 24th 2014


transit asm fault code P0919

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

transit asm fault code P0919

Postby Dennsit » Thu Sep 24, 2009 3:18 pm

Hello ,have been reading this forum for a couple of months now and hope there is some one with a solution...... ...
Fault code is P0919 gearshift position control error wiring connection ECM /PCM /TCM ... and thats as far as they can get .they have cleared the fault a couple of times but next morning the fault re-appears at first gear shift in to 2nd ,weather it is in auto or manual mode , but as soon as the vehicle is warmed up the fault dissappears and i could drive all day no probs ,they have checked the wiring for loose and have changed gearbox oil making no difference .last thing to know is the air bag light on instrument panel is constantly flashing .ANY help or pointers gretfully recieved and i will post the outcome if i get ressolution..many thanks
2001 transit
350l LWB
BHP 90 2.4 diesel mt 75 A....S....M
Last edited by Dennsit on Fri Sep 25, 2009 5:00 pm, edited 2 times in total.
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby Dennsit » Fri Sep 25, 2009 9:38 am

Hello. does any one Know if re mapping can help this problem ?
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby Dennsit » Fri Sep 25, 2009 4:36 pm

Can any one make any suggestions or is the van knackered ...beyond help
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby Altransit » Fri Sep 25, 2009 4:50 pm

I can't help you I'm afraid, but just to clarify, your van is a 2001, not 1991 ............ yes? :? With durashift?
1997 Mk5 SWB 115 Minibus 70ps Di
2004 Mk6 SWB T280 Medium Roof 85PS TDDi - Vantunered
User avatar
Altransit
Site Moderator
 
Posts: 21827
Joined: Tue Oct 17, 2006 12:23 am
Location: Bicester, Oxfordshire

Re: transit asm fault code P0919

Postby Dennsit » Fri Sep 25, 2009 4:59 pm

Thanks for the reply Altransit , yes it is a 2001 Y reg and it s a bit to good to scrap
....... just dont know the next best step ...anyone you could reccomend???
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby pikeybob » Fri Sep 25, 2009 5:49 pm

A manual gearbox :!:
The only mk7 still with ORIGINAL egr valve!!!!!!
User avatar
pikeybob
Transit Devotee
Transit Devotee
 
Posts: 690
Joined: Mon Oct 13, 2008 6:01 pm
Location: notts

Re: transit asm fault code P0919

Postby evans88 » Fri Sep 25, 2009 6:43 pm

What is actually happening first thing in the morning? You say the fault appears between first and second gear but what are the symptoms. Is it merley the auto light flashing on the bottom right of the instrument cluster?

If it just the auto light flashing that happens when you turn the ignition key too soon before the instrument lights are extinguished.
evans88
Transit Aficionado
Transit Aficionado
 
Posts: 196
Joined: Thu Jun 26, 2008 5:12 pm

Re: transit asm fault code P0919

Postby Dennsit » Fri Sep 25, 2009 7:49 pm

Thanks Evan.. this is how it goes ,turn on ignition every thing fine with no lights flashing select Drive, 1st gear , no probs and as i accelerate sounds fine then it disengages correctly as if it is going to change up into 2nd but it just returns to 1st instead ,this is the point at which the gearbox light flashes on the instrument panel .I then drop it into neutral ,select Drive and if the van is still moving it will go into 2nd or 3rd but will not change from that gear without me going through neutral, once the motor warms up none of these probs happen , ALL help is welcome and yes Pikeybob MANUAL is the correct answear ,thing is though i had a 1989 swb transit auto P 100 and it never gave any trouble...
Last edited by Dennsit on Mon Sep 28, 2009 4:15 pm, edited 1 time in total.
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby evans88 » Fri Sep 25, 2009 8:34 pm

That is interesting. Everything is fine when the engine is warm. I have heard of a similar fault on a Fiat Comfortmatic which is an automated manual and the problem was down to the oil used in the gearbox. That might explain why your gearbox works fine after being run. It doesn't explain why it works in manual and not auto but I do not think the fault is necessarily electrical.

However, as the garage has replaced the oil I can't think of a solution and neither can your garage by the sound of it.

One possible solution might be to trawl some American forums as the Durashift Box is used widely over there on cars and taxis in particular.

Keep us posted as the knowledge base for these gearboxes is very low in the UK.
evans88
Transit Aficionado
Transit Aficionado
 
Posts: 196
Joined: Thu Jun 26, 2008 5:12 pm

Re: transit asm fault code P0919

Postby Dennsit » Fri Sep 25, 2009 9:35 pm

Thanks Evans88 trawling USA sites ,had not thought of that ,will have a go and let you know.

Just to clear things up it does not work in auto or manual properly when it is cold , i have tried it from a standing start in manual and when it is the correct time to change in to 2nd and i use the gear shift paddle it does the same ..disengages 1st as if it will engage 2nd and just returns to 1st gear with the box light flashing on the dash. on the previous post i mentioned selecting neutral button ,then the Drive button it is because that is the only button that i can press that will do any thing ...i havn,t tried reverse whilst giong forwards .....yet
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby spanner-86 » Sat Sep 26, 2009 1:49 am

has your local garage tried the bleed proceedure using the diagnostic software,
have a check underneath on the unions as the copper washers corrode and leak or block the pipes, they go green
other than than that i have replaced control units due to loss of drive

i like to get it on a ramp and run it up and watch the gears change underneath that way you can see whats going on
spanner-86
Transit Addict
Transit Addict
 
Posts: 78
Joined: Sun Jan 04, 2009 3:27 pm

Re: transit asm fault code P0919

Postby Dennsit » Sat Sep 26, 2009 2:33 pm

Hello Spanner , i do Know that they bled it after they did the gearbox oil change but i doubt they used diagnostic software as by there own admission they dont have a ford IDS ....

Secondly , do you thnk the copper corrosion to the pipes could cause this intermittent and persistent fault.

Thirdly ,at what point do i replace the control unit how successful is this and any idea on a cost.

Thanks all for your help so far, i have tried USA sites with no luck so far, so any links for a good site
over ther would assist. CHEERS
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby Dennsit » Sun Sep 27, 2009 2:15 pm

Hi , just need to ask again if any body Knows if re-mapping can help with this ...or can they refere me to somebody who would know .CHEERS chaps
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Re: transit asm fault code P0919

Postby evans88 » Sun Sep 27, 2009 3:08 pm

You might like to indicate where you live if you want recommendations for a gearbox specialist who might help.

I have looked through a couple of American sites for you because in the past I have seen references to Durashift boxes on a trucking and a taxi forum. However, I was unable to find anything that would help.

Another suggestion. You could do a search on this site for Durashift problems, look up the threads and then send the instigators a Private Message (via the Members list by clicking Members in the top right hand corner of this page) to ask how they resolved their problems and who did the fix.
evans88
Transit Aficionado
Transit Aficionado
 
Posts: 196
Joined: Thu Jun 26, 2008 5:12 pm

Re: transit asm fault code P0919

Postby Dennsit » Sun Sep 27, 2009 4:04 pm

Thankevans ,i will have a look for Durashift thread on here and i am about 5 miles south of Lincoln CHEERS
Dennsit
Transit Addict
Transit Addict
 
Posts: 58
Joined: Thu Sep 24, 2009 2:24 pm

Next

Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot]