Transitmania 10 @Santa Pod 18th to 20th May 2018


Transit Connect dash/electrical problems

Use this section to post all specific Transit Connect topics and questions

Transit Connect dash/electrical problems

Postby RAM1889 » Sun Jan 15, 2012 6:20 pm

Hi evryone im new to the forum and this is my first post!
Iv just bought myself a 05 connect T220 LWB 1.8 TDDI. As i was driving home yesterday all the gauges on the dash (fuel, speedo, rev counter and temp) all died and then flicked back to life. This happened intermitently all the way home. Also i dont know if this is related fault or not but, when driving a night with the lights on and the heater blower on, the lights dim ever so slightly and and the noise from the blower drops a little before both flick back to full power. I have little knowledge of electrics so any help at all would be much appreciated!! Thanks
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Sun Jan 15, 2012 6:36 pm

I forgot to mention, as the gauges die the ABS light flicks on for a split second!
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby Highlander250469 » Sun Jan 15, 2012 6:38 pm

Ignition relay possibly
User avatar
Highlander250469
MK3 Massive
 
Posts: 861
Joined: Wed May 02, 2007 6:52 pm
Location: Ayrshire, Scotland

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Sun Jan 15, 2012 6:40 pm

Thanks! Any ideas on cost or ease of fix?
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby valetech » Sun Jan 15, 2012 6:42 pm

I had a problem with the dials, a bit like yours

It was 3 blown fuses.I would also check the connector on the back of the clocks
molested by:
Image

19s is how we roll
User avatar
valetech
Transit Devotee
Transit Devotee
 
Posts: 1643
Joined: Wed May 11, 2011 10:58 pm
Location: bishops stortford hertfordshire

Re: Transit Connect dash/electrical problems

Postby Highlander250469 » Sun Jan 15, 2012 6:43 pm

Wouldn't imagine they are that expensive, as to ease of fix you just pull it out and replace it.

It may be the pins are corroded and just need a clean though or it could be a wiring problem
User avatar
Highlander250469
MK3 Massive
 
Posts: 861
Joined: Wed May 02, 2007 6:52 pm
Location: Ayrshire, Scotland

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Sun Jan 15, 2012 6:48 pm

I thought of the fuses but according to the manual the fuse with the instrument cluster also has the hazard flasher on and seeing as though the hazards still work i guessed it wasnt that.
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Mon Jan 16, 2012 9:52 pm

Just been been sat in the van, the lights and heater blower both seem to drop away then come back to full power when you rev the engine. Could this be an alternator problem?
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby KH_Towbars » Mon Jan 16, 2012 9:59 pm

Take a look at this, maybe the same problem http://forums.digitalspy.co.uk/showthread.php?t=1409012
VW T5 102 SWB
R.I.P MK6 FWD 2.0TDDI Duratorq, EGR mod, K&N air filter, 16"alloys
User avatar
KH_Towbars
Transit Devotee
Transit Devotee
 
Posts: 1092
Joined: Sat Dec 19, 2009 5:16 pm
Location: Rotherham, South Yorkshire

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Mon Jan 16, 2012 10:23 pm

Thanks! Do you think it could be the same problem? The focus dash issues all seem to be around 2002, you would have hoped ford would have sorted it 3 years later!
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby KH_Towbars » Mon Jan 16, 2012 10:32 pm

RAM1889 wrote:Thanks! Do you think it could be the same problem? The focus dash issues all seem to be around 2002, you would have hoped ford would have sorted it 3 years later!

I would say yes and it is the 1st thing I would try (the soloution that is) theres plenty of info take your pick
VW T5 102 SWB
R.I.P MK6 FWD 2.0TDDI Duratorq, EGR mod, K&N air filter, 16"alloys
User avatar
KH_Towbars
Transit Devotee
Transit Devotee
 
Posts: 1092
Joined: Sat Dec 19, 2009 5:16 pm
Location: Rotherham, South Yorkshire

Re: Transit Connect dash/electrical problems

Postby RAM1889 » Mon Jan 16, 2012 11:10 pm

Ill start trying some of the solutions thanks!!!
RAM1889
Transit Addict
Transit Addict
 
Posts: 21
Joined: Sun Jan 15, 2012 2:51 am

Re: Transit Connect dash/electrical problems

Postby Terry mac » Fri Dec 14, 2012 3:22 pm

Hi im new to this forum, and was just wondering if anyone could help. Ive got an 05 transit connect, i got it about a year ago, when i got the van all the lights on the instrument cluster worked but all of a sudden the bottom 3 dont come on when ignition is switched on, i think it may have been after the battery was replaced but not 100% sure, does anyone know why this could be? I have had it looked at by a mechanic and he says it looks like something has been spilled an the leds on them 3 lights dont work amymore, but i have never spilled anything in the van, is this possible and can the leds be fixed ? Any help would be appreciated thanks terry
Terry mac
Newbie
 
Posts: 1
Joined: Fri Dec 14, 2012 2:59 pm


Return to Transit Connect



Who is online

Users browsing this forum: No registered users