Transitmania 10 @Santa Pod 18th to 20th May 2018


Sheared off engine mount?

Use this section to post all specific Transit Connect topics and questions

Sheared off engine mount?

Postby DaveMoleski » Wed Apr 18, 2018 8:50 pm

Hi all,

I have a 2007 Transit Connect. Whilst pulling away today I heard a loud crack/thump from under the front end and for the rest of the drive home it was impossible to shift through gears 1-3 without the van jolting and making a similar thumping sound. Had a little look underneath - my best guess is this is a sheared off engine mount? Could anyone confirm? It's possible to rock the whole engine backwards and forwards. It doesn't look corroded... Thanks for your help in advance.

IMG_3799.JPG
You do not have the required permissions to view the files attached to this post.
DaveMoleski
Newbie
 
Posts: 2
Joined: Wed Apr 18, 2018 8:44 pm

Re: Sheared off engine mount?

Postby Piglet » Thu Apr 19, 2018 6:37 am

I can't view your photo but sounds like the dogbone mount.
lives underneath between back of gearbox & subframe.
Not expensive, easy to fit IF the bolts come out.

Sorry, image has loaded now, that doesn't look anything like the dogbone mount on my 08. But it's definitely busted whatever it is.
Or is it the dogbone bracket?
Piglet
Transit Aficionado
Transit Aficionado
 
Posts: 376
Joined: Fri Jun 06, 2014 12:04 pm

Re: Sheared off engine mount?

Postby DaveMoleski » Thu Apr 19, 2018 12:34 pm

Cheers, Piglet. Yeah, I’ve had another look in the daylight and I’m pretty sure it’s the bracket. I might change the mount at the same time as it was an advisory on my last MOT. It also looks like one of the bolts on the mount has pulled out and stripped the thread. Maybe the best thing is to helicoil it? Funny that the bracket has completely snapped. It doesn’t look corroded at all.
DaveMoleski
Newbie
 
Posts: 2
Joined: Wed Apr 18, 2018 8:44 pm

Re: Sheared off engine mount?

Postby Kenton » Thu Apr 19, 2018 9:01 pm

If this is the gearbox bracket, i had mine changed when i took ownership of my van as we 'noticed' a lot of excess movement when we rocked the engine from underneath. This was caused by the bushes being totally worn out on the bottom gearbox bracket. I hadn't noticed much wrong at the time ironically!. This MAY have caused yours to shear, as when the bushes are so badly worn, the engine transmits a lot of vibration thought this part and eventually leads to it giving way, and it looks as though it has gone more or less in the middle. Apparently, these are very commonly wearing parts for my van. It will probably mean the same for yours being it is generally the same construction underneath. Check all other engine mounts for integrity and replace it. Just my tuppence worth. Good luck pal, do let us know how the bushes look on the removed bits, be very interested to know.
K
Connect 05 T230 LX 90 LWB
ST 17" alloys & Toyo Proxes
Focus ST170 seats
Fiesta Zetec steering wheel & G/K
Mondeo Door handles & vents
C/F Bonnet wrap
Side bars
Facelift rear lights
Fully lined & carpeted
K&N Panel filter
Lowered
User avatar
Kenton
Transit Aficionado
Transit Aficionado
 
Posts: 121
Joined: Thu Feb 05, 2015 10:09 am
Location: Surrey

Re: Sheared off engine mount?

Postby Piglet » Thu Apr 19, 2018 10:41 pm

If the mount was shot then the bracket would have been getting a hard time. It is possible the bolt just fell out under vibration, you never know your luck.
Piglet
Transit Aficionado
Transit Aficionado
 
Posts: 376
Joined: Fri Jun 06, 2014 12:04 pm


Return to Transit Connect



Who is online

Users browsing this forum: Google Adsense [Bot]