Transitmania 9 @Santa Pod 23rd - 24th September 2017 Click here for details!


66 plate adblu and exhaust filter faults

The all new 2013 Transit Mk8 Forum. Transits 2013+

66 plate adblu and exhaust filter faults

Postby D2flojo » Wed Apr 19, 2017 7:49 pm

I have a new 66plate transit. Only done 14000 miles. On 6000 miles I had a update for dpf. On 14000 I had problems with adblu engine oil change and cleaning of diesel filter. It was in Ford for 2 days had a wiring upgrade for adblu a software update and cry cleared of faults. 30 miles down road engine management light came on. Took it back and had codes wiped and was told to monitor. Since then I have done 100 miles and it has tried regenerating dpf 4 times. Every time it cleans I am on motorway doing 60. Has any one else had problems
D2flojo
Newbie
 
Posts: 2
Joined: Wed Apr 19, 2017 7:24 pm

Re: 66 plate adblu and exhaust filter faults

Postby TaysideTransit » Sun Apr 23, 2017 4:51 pm

What kind of transit do you have?

I am on the 17 seat MK8 minibus. Done 5,000 miles in the last 5 weeks. So far so good, except for the limiter. its meant to be set to 62mph but ford have released them all with speeds up to 70mph. (no use for PSV tacho).

Because i've got the new 'panther' engine the software the dealer has isn't up to date. They can only set it to a maximum speed of 59mph (58mph on cruise). Very frustrating trying to pass lorries. Getting nowhere with ford on the issue.

I did notice it has got through a few litres of adblue already. Been told not to worry about the DPF as they "burn clean as a whistle" We will see on that one!!
TaysideTransit
Newbie
 
Posts: 3
Joined: Mon Mar 13, 2017 11:42 pm

Re: 66 plate adblu and exhaust filter faults

Postby TaysideTransit » Sun Apr 23, 2017 4:51 pm

2017 plate i forgot to add
TaysideTransit
Newbie
 
Posts: 3
Joined: Mon Mar 13, 2017 11:42 pm


Return to Mk8 Fourth Generation Transits



Who is online

Users browsing this forum: No registered users