Transitmania 11 @Santa Pod 17th to 19th May 2019


Fuel system troubles

Use this forum to post technical questions & problems about any Transit

Moderator: Luke

Fuel system troubles

Postby martinxt » Fri Oct 12, 2018 5:00 pm

Hello,

I’ve just changed some parts on the fuel system for my mk7 2.2 fwd. Namely, the SCV, PRV and the fuel rail pressure sensor. I’ve put it all back together and this is where my issues have started.

Plugged into a computer the following codes are present:

1. P0190:15-2F FRP sensor
2. P268B pump learn not completed
3. U0401 invalid data received from ECM/PCM

Looking at the live data the FRP sensor has a constant 5v output reading max fuel pressure. I had to destroy the original sensor to get it out but I’ve tried two different new ones with the same result.

The engine runs but revs up very slowly, assuming because it doesn’t want to demand any more fuel pressure.

What am I missing here? Any help will be gratefully received.
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby martinxt » Fri Oct 12, 2018 6:28 pm

Reading up on code P0190 it suggests a fault with the wiring, short or open circuit. There was no problem with the wiring before but now there’s a new sensor in there it is say there is.
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby Airthies » Fri Oct 12, 2018 6:57 pm

Where did you get the sensors? I wouldn't trust aftermarket eBay or motor factor ones personally.
Why did you change it? Just curious, as in general I wouldn't change sensors unless they're faulty.
Also where did you get the SCV & PRV? Also best to get genuine valves either Ford or somewhere like PF Jones.


Sent from my anu5 using crapatalk
Back now, well for a bit anyway.....
2008 350LWB 115PS ex welfare van
2008 350LWB 115PS ex fitters van + other things....
V86+patch
V86.04
X-Prog
C81
User avatar
Airthies
Transit Fanatic
Transit Fanatic
 
Posts: 3194
Joined: Fri May 03, 2013 10:10 pm
Location: Stirling, Scotland, & rest of the world

Re: Fuel system troubles

Postby martinxt » Fri Oct 12, 2018 7:30 pm

I did indeed buy it off eBay, it came as part of a kit containing scv, prv and fuel rail pressure sensor. Surely not all the ones off eBay are garbage? I bought a second sensor from someone else, also on eBay and exactly the same symptoms.

Originally I changed these parts because the engine was hunting at idle, sometimes almost to the point of cutting out.
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby Airthies » Fri Oct 12, 2018 11:12 pm

It may not be just the sensor, it may be either the PRV or SCV or a combination of all three that are just slightly out and creating issues.

Sent from my anu5 using crapatalk
Back now, well for a bit anyway.....
2008 350LWB 115PS ex welfare van
2008 350LWB 115PS ex fitters van + other things....
V86+patch
V86.04
X-Prog
C81
User avatar
Airthies
Transit Fanatic
Transit Fanatic
 
Posts: 3194
Joined: Fri May 03, 2013 10:10 pm
Location: Stirling, Scotland, & rest of the world

Re: Fuel system troubles

Postby andz327 » Fri Oct 12, 2018 11:16 pm

martinxt wrote:I did indeed buy it off eBay, it came as part of a kit containing scv, prv and fuel rail pressure sensor. Surely not all the ones off eBay are garbage? I bought a second sensor from someone else, also on eBay and exactly the same symptoms.

Originally I changed these parts because the engine was hunting at idle, sometimes almost to the point of cutting out.
How much did you pay for them and from who ??????
You'd be surprised how many shit parts are out there mate

Sent from my LG-H870 using Tapatalk
User avatar
andz327
Transit Fanatic
Transit Fanatic
 
Posts: 2922
Joined: Thu Jan 14, 2016 3:44 am

Re: Fuel system troubles

Postby martinxt » Sat Oct 13, 2018 12:12 am

It was £115 for the set from a company called parts4uuk
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby knobby1 » Sat Oct 13, 2018 8:30 am

martinxt wrote:It was £115 for the set from a company called parts4uuk


If they're that cheap...they're not worth the money you've paid. We've been through and over this a thousand times.....buy cheap, buy twice.
Our experience tells us the cheap ebay valves will never work properly and the learns will fail every time. They need to be genuine Ford/Denso items....and they are expensive.

Lord Knobrot
2008 2.4L RWD 170+PS 6-speed 350 LWB High Roof.

When I die, I want to go peacefully in my sleep like my Grandfather, not screaming like the passengers in his car..!
User avatar
knobby1
Transit Extremist
Transit Extremist
 
Posts: 6916
Joined: Tue Oct 21, 2014 1:36 am
Location: Sydney, Australia

Re: Fuel system troubles

Postby martinxt » Sat Oct 13, 2018 9:15 am

So it seems fairly unanimous then, buy genuine parts. Is there anywhere other than direct from Ford that you guys would recommend? Ford seem to add quite a markup. A combination of being tight fisted and skint.

The only thing that’s still confusing me is, when I’m reading the live data, the fuel rail pressure, and the electrical output that this is derived from, remains at maximum all the time. Even if I disconnect the sensor it doesn’t change, surely there should be some fluctuations
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby Airthies » Sat Oct 13, 2018 10:02 am

Check the wiring first then.
Wiring goes from sensor to PCM plug C1 (first one you take off closest to the cab)
Sensor - colour - PCM pins
Pin 1 = OG-BU = C1-A4
Pin 2 = BU-BN = C1-A3
Pin 3 = BN-BY = C1-C1

Sent from my anu5 using crapatalk
Back now, well for a bit anyway.....
2008 350LWB 115PS ex welfare van
2008 350LWB 115PS ex fitters van + other things....
V86+patch
V86.04
X-Prog
C81
User avatar
Airthies
Transit Fanatic
Transit Fanatic
 
Posts: 3194
Joined: Fri May 03, 2013 10:10 pm
Location: Stirling, Scotland, & rest of the world

Re: Fuel system troubles

Postby martinxt » Sat Oct 13, 2018 10:24 am

Excellent, thanks very much. I was looking for a wiring diagram but haven’t been able to track one down.

I’ll get out and check them once this bloody weather calms down a bit.
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby martinxt » Sat Oct 13, 2018 1:16 pm

Ok so I’ve been and checked the wiring and found no shorts and no open circuit.

What I did find though is that pins 1 and 3 on the sensor are the opposite to what was suggested.

So pin 1 of the sensor went to c1 and pin 3 went to a4. That’s pins 1 and 3 as printed on the sensor and would have been the same on the old one, I still have the mangled remains of it.
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby bambi mk 1 » Sun Oct 14, 2018 11:26 am

Always retrace your steps :wink: You hadnt this problem before you changed parts :?: :wink: The rail sensor at the front of the rail never gives trouble but if you leave it disconnected it will give the problem you have.I am not 100% sure but I think you have to buy the complete rail from Ford :shock: If you are having problems I should have a used one but will take a few days to get to you :) You could try this man for good quality parts and send back the ones you have http://dohertytransitparts.com/?gclid=E ... gLbUfD_BwE
Theres the good guys,theres the bad guys but there only ever be one SPEED GUY
User avatar
bambi mk 1
Transit Extremist
Transit Extremist
 
Posts: 6282
Joined: Sat Nov 17, 2012 10:05 pm
Location: 24 Years living next door to Alice

Re: Fuel system troubles

Postby martinxt » Sun Oct 14, 2018 12:25 pm

Ok so been out this morning and had a play about with the two new sensors I have. One is giving me all the problems above but allows the van to start and run, albeit rough. The other is slightly different, all the trouble codes disappear leaving only the one that says the pump learn hasn’t been completed, but the van will not start. It looks to me that everything is pointing at this sensor or am I just getting tunnel vision?
martinxt
Transit Fan
Transit Fan
 
Posts: 15
Joined: Mon May 29, 2017 9:15 pm

Re: Fuel system troubles

Postby bambi mk 1 » Sun Oct 14, 2018 12:34 pm

Have you read my post :?: The more things you play at the more things can give you problems sometimes :wink:
Theres the good guys,theres the bad guys but there only ever be one SPEED GUY
User avatar
bambi mk 1
Transit Extremist
Transit Extremist
 
Posts: 6282
Joined: Sat Nov 17, 2012 10:05 pm
Location: 24 Years living next door to Alice

Next

Return to Technical Problems & Questions



Who is online

Users browsing this forum: No registered users