Transitmania 12 @Santa Pod 15th to 17th May 2020


MK 6) jumpy speedo / gauges, flickering dash lights

Before you ask a question, check to see if it's been asked before. We show all the common Transit faults here and it's a good idea to read through these in case they happen to you in the future!!

MK 6) jumpy speedo / gauges, flickering dash lights

Postby APH » Tue Aug 21, 2007 10:04 pm

If you have a Mk6 van that the speedo needle "jumps" from 0 to 10 Mph when idling, or the fuel guage / temp guage wobbles for a few seconds after starting, or any of the guages take a while to respond even when driving (sometimes odd warning lights can flicker on and off too), its is usually due to one of the following.

Either the multiplug connections on the back of the instrument cluster are making bad contact, and should be removed, sprayed with good contact cleaner then pushed on and off several times to "clean" the pins...or if that fails to resolve the issue...

Your charging voltage has become unstable (usually more noticeable just after starting), and is 9 times out of 10 due to a failing battery (regardless of what charging voltage is when checked with a multimeter) These vans require a steady voltage for the electronic guages to work correctly, and any variation can cause strange effects with the instrument cluster and sometimes the radio! .......

As a last resort your alternator should be checked, but only if the above dosent solve the problem.
User avatar
APH
Transit Fanatic
Transit Fanatic
 
Posts: 2385
Joined: Thu Apr 12, 2007 7:29 pm
Location: Gravesend, Kent

Re: MK 6) jumpy speedo / gauges, flickering dash lights

Postby Treadmark » Sun Oct 04, 2020 10:23 pm

Hi
Great thread . My minibus I noticed has gauges that work sometimes and a stereo that turns off when fan gets out on ! Guessing it’s down to the crap battery!
Thanks !
Treadmark
Newbie
 
Posts: 8
Joined: Sun Oct 04, 2020 8:32 pm


Return to Frequently asked questions!!



Who is online

Users browsing this forum: No registered users

croncroncron