Transitmania 11 @Santa Pod 17th to 19th May 2019


Euro 5 mk7.5 high fuel pressure poor start and rough running

Transit Mk6 & Mk7 Forum. All Transits 2000 - 2013

Euro 5 mk7.5 high fuel pressure poor start and rough running

Postby roperman » Thu Jun 14, 2018 5:54 pm

Hi,

I've got a 2013 2.2 euro 5 RWD transit minibus that has refused to start a couple of times recently. And once it did it ran rough until it had been restarted a couple of times. The vehicle has 9000 miles on it so shouldn't have anything worn out on it. After a couple of goes it will run fine and not do this until its been sat for a bit.

Fault codes from IDS are:
P0088:00 fuel pressure too high - generic
P0088:24 fuel pressure too high - signal stuck high
P228D - Fuel Pressure Regulator 1 Exceeded Control Limits Pressure Too High

As its a low miles bus thats hardly done any work i'm wondering if its just the pressure switch. Anyone else have this fault?

I also noticed in the snapshot data that the ECU voltage at the time was 10v, is this a bit low? Could it be causing the ecu to shut off and therefore not control the inlet metering valve properly and resulting in an overpressure?

Or could it be something as mundane as needing a new fuel filter? (It had one at 3k)

Danny
roperman
Transit Addict
Transit Addict
 
Posts: 39
Joined: Tue Jun 02, 2015 12:52 am

Re: Euro 5 mk7.5 high fuel pressure poor start and rough run

Postby v8dave » Fri Jun 15, 2018 12:27 am

is it not still under warranty ?
mk7 08reg 2.4 T350 LWB MHR RWD
mk6 X reg 2.4 T350 LWB MHR RWD - scrapped
mk4 J reg 2.5 L300 LWB MHR RWD - sold on

Notice a trend there ? not too big and not too small
User avatar
v8dave
Transit Fanatic
Transit Fanatic
 
Posts: 2772
Joined: Sun Jan 24, 2010 10:23 pm
Location: Home counties

Re: Euro 5 mk7.5 high fuel pressure poor start and rough run

Postby roperman » Fri Jun 15, 2018 12:01 pm

I doubt it. its over 5 years old, i've no idea what the warranty would be on these but we bought it at auction. It was owned by a council in essex before us and never got used. We had a list of all the jobs its been used on and it fit on 1 piece of a4!

It runs fine when its running, which makes me suspect the battery. It only ever does it when starting after its been stood. And thinking about it the tacho always comes up "power interruption" at the same time which is telling me that the battery voltage has dropped too low. I'll try swapping the batteries over from another bus.

Just seems an odd fault as it initially refuses to start, then puts itself in limp mode, but seems to clear when you turn it off after leaving it a while. Its hard to replicate but I might try starting it with the fan on full and lights on first thing in the morning after its been stood a while to replicate a voltage drop, whilst having IDS plugged in looking at battery voltage, fuel rail pressure etc.

Danny
roperman
Transit Addict
Transit Addict
 
Posts: 39
Joined: Tue Jun 02, 2015 12:52 am

Re: Euro 5 mk7.5 high fuel pressure poor start and rough run

Postby roperman » Fri Jun 15, 2018 4:21 pm

Right,
I've plugged in IDS and tried to replicate it, but it decided to be fine today.

Video here: https://www.youtube.com/watch?v=QjSqc_KvnUU&feature=youtu.be

I noticed that the fuel rail pressure kept jumping above zero when the van was off (it had been stood overnight so shouldn't have been pressurised) but it could well be a normal sensor fluctuation.

I also noticed that the voltage the ecu was seeing when cranking dropped to 8.5v, which seems a little on the low side.

Which of these should I be more worried about?

Danny
roperman
Transit Addict
Transit Addict
 
Posts: 39
Joined: Tue Jun 02, 2015 12:52 am


Return to Mk6 & Mk7 - Third Generation Transits



Who is online

Users browsing this forum: Bing [Bot], Google [Bot]