Transitmania 11 @Santa Pod 17th to 19th May 2019


2004 Transit Connect TDCi smoke on start up and limp

Use this section to post all specific Transit Connect topics and questions

2004 Transit Connect TDCi smoke on start up and limp

Postby _matt » Tue Aug 21, 2018 3:27 pm

Ok so when i first start my van i get a lot of grey smoke and it drives a bit lumpy for about a minute then the smoke goes away and it drives normally.

The smoke is coming out of the exhaust and out of the flex part below the engine also

Secondly sometimes (usually accelerating to or at 50/60mph) i get the yellow coil light and the power cuts, i can just turn off and back on the engine and it works again but with reduced power (wont rev past 3k ish).

are these two issues linked? I CANT read any codes as i have tried 4 different code readers in the obd port (physical reader, direct to laptop, direct to tablet and bluetooth) and nothing can connect.

What should i start replacing to remedy this? Full oil and oil filter, air filter change all done recently.

I have the fuel filter to do this weekend.

Glow plugs are pretty cheap so i was thinking of doing these next
_matt
Transit Addict
Transit Addict
 
Posts: 27
Joined: Mon Nov 28, 2016 11:08 am

Re: 2004 Transit Connect TDCi smoke on start up and limp

Postby Kenton » Tue Aug 21, 2018 8:33 pm

If it's anything like mine, then the glow plugs will be shot. I don't think this is your problem here though. It would most likly be the injectors. I changed my glow plugs about 2 years ago when we found none of them worked, and made no difference to the symptoms i was having - which were the same as yours. The problems with cutting out only happened way after the Smokey starts and lumpy cold running had been occurring for a long time, possibly a couple of years! I have recently replaced my injectors with refurbished ones, and it has cured every single symptom. This by no means is your DEFINITIVE problem, so also consider getting your ECU codes read by someone who has a COMPATIBLE scanner and post them back here so the experts can cast their eye over them. All the best pal.
Connect 05 T230 LX 90 LWB
ST 17" alloys & Toyo Proxes
Focus ST170 seats
Fiesta Zetec steering wheel & G/K
Mondeo Door handles & vents
C/F Bonnet wrap
Side bars
Facelift rear lights
Fully lined & carpeted
K&N Panel filter
Lowered
User avatar
Kenton
Transit Aficionado
Transit Aficionado
 
Posts: 199
Joined: Thu Feb 05, 2015 10:09 am
Location: Surrey

Re: 2004 Transit Connect TDCi smoke on start up and limp

Postby _matt » Wed Oct 10, 2018 2:16 pm

Ok so changed fuel filter and no difference!

Injectors then, do these need to be coded? This would be an issue as the OBD port doesnt work
_matt
Transit Addict
Transit Addict
 
Posts: 27
Joined: Mon Nov 28, 2016 11:08 am

Re: 2004 Transit Connect TDCi smoke on start up and limp

Postby axxeman » Tue Oct 16, 2018 10:39 am

_matt wrote:Ok so changed fuel filter and no difference!

Injectors then, do these need to be coded? This would be an issue as the OBD port doesnt work


OBD port will need fixing first as injectors are coded on this year - and you can't read the stored fault codes with it not working, either.
axxeman
Transit Aficionado
Transit Aficionado
 
Posts: 244
Joined: Sat Mar 01, 2014 1:43 pm


Return to Transit Connect



Who is online

Users browsing this forum: No registered users