Transitmania 10 @Santa Pod 18th to 20th May 2018


Loss of power 2004 TDDI

Use this section to post all specific Transit Connect topics and questions

Loss of power 2004 TDDI

Postby matt7159 » Mon May 21, 2018 7:16 pm

Hi all
This starts over 4 years ago ,had problem with engine can't quite remember what , it went to a place in Slough called remanufactured engines ,sure they were called something else before that .
Engine was refurbished and was told it had no power , I was short of cash so I brought it home , it struggled to get above 55mph .
I later found out the place was already closed once by trading standards! ,and it was known for fleecing people
I gat a mate to look it over found a few issues b oaken wires and we put a new genuine ford egr on ,it would do 70 and a little more ,but it just lacked any go like it had no turbo , but it idles nice and even ,and probably uses a little more fuel than it did before .
I finally got fed up with it and it's been in a garage the only fault it came up with was egr but expected that after the new egr valve.
The turbo has been refurbished ,pump & injectors checked and all ok it runs and drives fine apart from the lack of power ,the garage is almost out of ideas ?
And I don't really want to put it into a ford garage as that would be mega bucks for a master tech to look at it .
I need some help!


Sent from my iPad using Tapatalk
User avatar
matt7159
Newbie
 
Posts: 5
Joined: Fri Jun 27, 2014 8:44 am
Location: Tadley

Re: Loss of power 2004 TDDI

Postby Kenton » Tue May 22, 2018 4:08 pm

Check the small thin black plastic boost pipe that comes from the EGR valve across into a black sensor. This is something to do with regulating boost pressure (i think) and if it is broken or cracked, it will leak giving a wrong reading. I had this and my van struggled to do 40mph. Worth a look!

Good luck pal.
Connect 05 T230 LX 90 LWB
ST 17" alloys & Toyo Proxes
Focus ST170 seats
Fiesta Zetec steering wheel & G/K
Mondeo Door handles & vents
C/F Bonnet wrap
Side bars
Facelift rear lights
Fully lined & carpeted
K&N Panel filter
Lowered
User avatar
Kenton
Transit Aficionado
Transit Aficionado
 
Posts: 189
Joined: Thu Feb 05, 2015 10:09 am
Location: Surrey

Re: Loss of power 2004 TDDI

Postby matt7159 » Thu May 24, 2018 6:38 pm

Kenton wrote:Check the small thin black plastic boost pipe that comes from the EGR valve across into a black sensor. This is something to do with regulating boost pressure (i think) and if it is broken or cracked, it will leak giving a wrong reading. I had this and my van struggled to do 40mph. Worth a look!

Good luck pal.
thanks it's getting its injectors checked at the moment ,it is producing boost which it wasn't before.
We have tried swapping out all the sensors intercooler,so didn't have much choice but to test injectors.


Sent from my iPad using Tapatalk
User avatar
matt7159
Newbie
 
Posts: 5
Joined: Fri Jun 27, 2014 8:44 am
Location: Tadley

Re: Loss of power 2004 TDDI

Postby matt7159 » Fri Jun 01, 2018 9:15 pm

We swapped my injectors for ones in a scrapper and BINGO she is all sweet now good result.


Sent from my iPad using Tapatalk
User avatar
matt7159
Newbie
 
Posts: 5
Joined: Fri Jun 27, 2014 8:44 am
Location: Tadley


Return to Transit Connect



Who is online

Users browsing this forum: No registered users