Transitmania 12 @Santa Pod 15th to 17th May 2020


Van wont start

Ford A-series 1974 - 1982

Moderator: Luke

Van wont start

Postby stevans.evans » Sun Nov 10, 2019 11:07 pm

When i try to start it sounds like the battery but the coil light flashes and it makes a clicking sound i have a video but it will not let me upload if any one can help i can email you the video

Sent from my Pixel 2 XL using Tapatalk
stevans.evans
Newbie
 
Posts: 1
Joined: Sun Nov 10, 2019 11:04 pm

Re: Van wont start

Postby Altransit » Mon Nov 11, 2019 3:14 pm

Some details about the van may help, e.g. which year, which engine, etc.

I don't know much about the A series, but there are a few here that do :)
1997 Mk5 SWB 115 Minibus 70ps Di (Gone, but not forgotten!)
2004 Mk6 SWB T280 Medium Roof 85PS 2.0 TDDi - Vantunered (Also gone)
2008 Mk7 SWB T280 Medium Roof 85PS 2.2 TDCi - Also Vantunered
User avatar
Altransit
Site Moderator
 
Posts: 33409
Joined: Tue Oct 17, 2006 12:23 am
Location: Bicester, Oxfordshire, UK

Re: Van wont start

Postby Chuggy » Tue Nov 12, 2019 12:01 am

From the description it sounds like flat battery, or if the battery is good, then the starter is playing up, but as Al said we need more info, engine, year etc and any other info that you recall that might help such as previous recent starting probs.
1991(J) twin wheel tipper 2.5di
1994(L) twin wheel tipper 2.5di
Chuggy
Transit Devotee
Transit Devotee
 
Posts: 910
Joined: Tue Jan 02, 2018 9:27 pm
Location: Tring, Hertfordshire


Return to Ford A-Series



Who is online

Users browsing this forum: No registered users

croncroncron