****NOW BOOKED FOR 2021**** Transitmania 12 @Santa Pod 16th to 18th July 2021 ****ALL DETAILS HERE****


P0299 all ready new turbo unit fitted

The all new 2013 Transit Mk8 Forum. Transits 2013+

P0299 all ready new turbo unit fitted

Postby zeemeester » Tue Sep 14, 2021 2:00 pm

Hallo, im reading this post with interest, because I have exactly the same problem with my van, 2016, 2.2 . Went to several dealers,
First a got code 2599 and 2598 .then the replaced sensors map, maf, intercooler,
Code was still comming then the cleaned dpg filter, this was not necessary he told me after,
Now they fitted a complete new turbo unit,and after 30km I get p0299.
When I turn the key the code is gone and I can drive approximately another 30km .when the engine is cold in the morning it comes on for about 5 or 6 times and then I can drive for about 30km , it's everytime p 0299 . It cost me a lot of money and irritating so far, can anyone help me thx
zeemeester
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Jun 11, 2021 9:22 pm

Re: P0299 all ready new turbo unit fitted

Postby zeemeester » Tue Sep 14, 2021 2:03 pm

It's a 2016 4x4 2.2 125hp, that I converted to a camper van,
zeemeester
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Jun 11, 2021 9:22 pm

Re: P0299 all ready new turbo unit fitted

Postby p2thed » Tue Sep 14, 2021 4:57 pm

do you know if they had reset the map,maf and turbocharger values in the pcm so its not running on the old values?

if the new sensors are okay/replaced. the only other thing that it might be is a Pcm issue or a fault within the wiring harness.
p2thed
Transit Aficionado
Transit Aficionado
 
Posts: 233
Joined: Sat Jul 03, 2010 6:10 pm

Re: P0299 all ready new turbo unit fitted

Postby zeemeester » Tue Sep 14, 2021 6:33 pm

The ford dealer told me its running the latesed software update, I assume they checked all that. Could it be the egr ?
zeemeester
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Jun 11, 2021 9:22 pm

Re: update P0299 all ready new turbo unit fitted

Postby zeemeester » Tue Sep 21, 2021 5:40 pm

i noticed that it happens often in the morning, if also happens offer in the mountains where the temp is only 15degrees, now I disconnected the intercooler temp sensor (a new one) and the malfunction does not come on, what happened ??
zeemeester
Transit Fan
Transit Fan
 
Posts: 17
Joined: Fri Jun 11, 2021 9:22 pm

Re: update P0299 all ready new turbo unit fitted

Postby mcbutler » Wed Sep 22, 2021 10:15 am

zeemeester wrote:i noticed that it happens often in the morning, if also happens offer in the mountains where the temp is only 15degrees, now I disconnected the intercooler temp sensor (a new one) and the malfunction does not come on, what happened ??

If you disconnet the sensor then I guess a set of stored default values in the ECU would take over.
It might be worth checking all your inlet air temps and engine breather hoses for a good fit. If the ECU sees a difference in air temps that should not be there itll generate a fault. Try doing a resistance check on the air inlet temp sensors
I had a stability error on my van for years when I went over 60mph, up a hill or on a left hand bend. It was the foil covered breather hose that runs from the valve cover to the inlet hose causing it!! I mean how obscure is that
mcbutler
Transit Addict
Transit Addict
 
Posts: 86
Joined: Tue Sep 15, 2020 8:06 pm


Return to Mk8 Fourth Generation Transits



Who is online

Users browsing this forum: No registered users