*NOW BOOKED FOR 2023* Transitmania 14 @ Santa Pod 12th & 13th August 2023 *ALL DETAILS HERE*


2015 custom 2.2

The all new 2013 Transit Custom Forum. Transits and Tourneos 2013+

2015 custom 2.2

Postby atchie1975 » Tue Jan 24, 2023 8:54 am

Hi to all. I've 2015 custom ltd. Recently the electric windows started to play up. Passenger side worked intermittently but has now also stopped along with the drivers door. When I have heated windscreen on, the indicator light on drivers mirror comes on :shock:
I have tried a different switch with no joy. I know there are issues with the loom at doors hinge :( So just wondering if anyone has any ideas? Is it a new loom or getting a spark to look at it? Need to get the drivers window working for MOT. Oh, one more bit of info... There was a sound from switch (almost like a tiny buzz) when the drivers switch was engaged when working intermittently, but no sound at all now. Just in case that makes any sense to anyone. Any advice or help appreciated.
Thank you, Alfie
atchie1975
Newbie
 
Posts: 2
Joined: Tue Jan 24, 2023 8:30 am

Re: 2015 custom 2.2

Postby CMGolds » Tue Jan 24, 2023 3:32 pm

Try pulling back the rubber between the drivers door pillar and the door, you should be able to see any broken wires. I changed a drivers door loom recently it wasn't until i unwrapped the tape in the middle of the loom (the bit between the pillar and door) i found all the broken wires, i think there was 6 broken in total with 2 rubbing together.
CMGolds
Newbie
 
Posts: 8
Joined: Tue Sep 06, 2022 3:10 pm

Re: 2015 custom 2.2

Postby atchie1975 » Wed Jan 25, 2023 8:30 am

Thank you. Think I'm just going to bite the bullet and get a new loom at £150. It all points to this loom. Just hope it is. Thanks again.
atchie1975
Newbie
 
Posts: 2
Joined: Tue Jan 24, 2023 8:30 am


Return to Transit Custom



Who is online

Users browsing this forum: No registered users